Linux для пользователя



         

Программа rpm - часть 3


redhat-logos нужен для mc-4.5.30-12

libglib-1.2.so.0 нужен для mc-4.5.30-12

libc.so.6(GLIBC_2.1) нужен для mc-4.5.30-12

libc.so.6(GLIBC_2.0) нужен для mc-4.5.30-12

Это не удивительно, если вы вспомните, что и при первоначальной установке Linux программа инсталляции тоже проверяла взаимозависимости пакетов и предлагала установить недостающие. Однако в случае инсталляции с CD-ROM все необходимые пакеты находятся на том же диске, а здесь мне пришлось вначале поискать нужные пакеты. Два пакета (redhat-logos-1.0.5-1.noarch.rpm и glibc-2.1.1-6.i386.rpm) я нашел без труда, после чего rpm перестала просить и GLIBC_2.0. А вот с libglib.so.1 вышло сложнее. Во-первых, я никак не мог найти пакета с таким названием. Как оказалось, такого пакета и не существует, файл libglib.so.1 входит в состав пакета glib-1.0.6-3.i386.rpm.

Программа rpm позволяет выяснить, какие файлы установит тот или иной пакет. Для этого надо дать следующую команду (только учтите, что текущим должен быть каталог, содержащий интересующий вас пакет):

[root]# rpm -qpl имя_rpm-архива

А для получения информации о том, для чего служит ПО, содержащееся в rpm-пакете, используйте команду

[root]# rpm -qpi имя_rpm-архива

Дело в том, что файлы RPM кроме собственно архива файлов содержат информацию о пакете, включая имя, версию и краткое описание. С помощью той же программы rpm вы можете просмотреть эту дополнительную информацию. Например, для пакета glib-1.0.6-3.i386.rpm вывод команды

[root]# rpm -qpi glib-1.0.6-3.i386.rpm

будет примерно таким:

Name : glib Relocations: (not relocateable)

Version : 1.0.6 Vendor: Red Hat Software

Release : 3 Build Date: Суб 10 Окт 1998 04:49:03

Install date: (not installed)

Build Host : porky.redhat.com

Group : Libraries Source RPM: glib-1.0.6-3.i386.rpm

Size : 55305

Packager : Red Hat Software <bug@redhat.com>

Summary : Handy library of utility functions

Description : Handy library of utility functions. Development libs and headers are in gtk+-devel.

Если дать команду:

[root]# rpm -qpl glib-1.0.6-3.i386.rpm




Содержание  Назад  Вперед